Solved Error Libdbusmenu-glib di Manjaro


Semalam ada upgrade dari manjaro, ketika proses download sudah selesai tinggal menuju upgrade paket, ternyata ada error pada libdbusmenu-glib. 

Berkali-kali saya coba pacman -Sy/pacman -Syu dan hapus file libdbusmenu-glib di /var/cache/pacman/pkg/ hasilnya tetap sama.

Begini errornya: 

Packages (31): assaultcube-1.2.0.0-2  avahi-0.6.31-11  bamf-0.5.0-2
               blueman-20131021git-2  bluez-5.9-1  bluez4-4.101-3 [removal]
               ffmpeg-1:2.1-2  firefox-25.0-1  firefox-i18n-en-us-25.0-1
               gnutls-3.2.6-1  gufw-13.10.3-1  harfbuzz-0.9.23-1
               harfbuzz-icu-0.9.23-1  keyutils-1.5.8-1  libbluray-0.4.0-1
               libdbusmenu-glib-12.10.2-3  libdbusmenu-gtk3-12.10.2-3
               libdnet-1.12-8  manjaro-welcome-0.8.8rc2-1  pavucontrol-2.0-2
               poppler-0.24.3-1  poppler-glib-0.24.3-1  sdl-1.2.15-5
               thunderbird-24.1.0-1  thunderbird-i18n-en-us-24.1.0-1
               uriparser-0.7.8-2  wavpack-4.70.0-2  xf86-input-keyboard-1.8.0-1
               xorg-server-1.14.4-1  xorg-server-common-1.14.4-1
               youtube-dl-2013.11.02-1

Total Installed Size:   226.72 MiB
Net Upgrade Size:       6.26 MiB

:: Proceed with installation? [Y/n] y
(30/30) checking keys in keyring                   [----------------------] 100%
(30/30) checking package integrity                 [----------------------] 100%
(30/30) loading package files                      [----------------------] 100%
(30/30) checking for file conflicts                [----------------------] 100%
error: failed to commit transaction (conflicting files)
libdbusmenu-glib: /usr/include/libdbusmenu-glib-0.4/libdbusmenu-glib/client.h exists in filesystem
libdbusmenu-glib: /usr/include/libdbusmenu-glib-0.4/libdbusmenu-glib/dbusmenu-glib.h exists in filesystem
libdbusmenu-glib: /usr/include/libdbusmenu-glib-0.4/libdbusmenu-glib/enum-types.h exists in filesystem
libdbusmenu-glib: /usr/include/libdbusmenu-glib-0.4/libdbusmenu-glib/menuitem-proxy.h exists in filesystem
libdbusmenu-glib: /usr/include/libdbusmenu-glib-0.4/libdbusmenu-glib/menuitem.h exists in filesystem
libdbusmenu-glib: /usr/include/libdbusmenu-glib-0.4/libdbusmenu-glib/server.h exists in filesystem
libdbusmenu-glib: /usr/include/libdbusmenu-glib-0.4/libdbusmenu-glib/types.h exists in filesystem
libdbusmenu-glib: /usr/lib/girepository-1.0/Dbusmenu-0.4.typelib exists in filesystem
libdbusmenu-glib: /usr/lib/libdbusmenu-glib.so exists in filesystem
libdbusmenu-glib: /usr/lib/libdbusmenu-glib.so.4 exists in filesystem
libdbusmenu-glib: /usr/lib/libdbusmenu-glib.so.4.0.12 exists in filesystem
libdbusmenu-glib: /usr/lib/pkgconfig/dbusmenu-glib-0.4.pc exists in filesystem
libdbusmenu-glib: /usr/share/gir-1.0/Dbusmenu-0.4.gir exists in filesystem
libdbusmenu-glib: /usr/share/vala/vapi/Dbusmenu-0.4.vapi exists in filesystem
Errors occurred, no packages were upgraded.

Nah dapet juga solusinya di Forum Manjaro http://forum.manjaro.org/index.php?topic=8081.msg71395#msg71395

Denga cara:

$ sudo pacman -Rdd libdbusmenu
$ sudo pacman -Sy libdbusmenu-glib

Akhirnya beres, mana tau ada temen lain yang punya nasib yang sama.